[PSQL] Błąd 3012

Radosław Pogonowski
Radosław Pogonowski
  • Zaktualizowano

Błąd oznaczający, iż lokalny motor bazy danych nie jest dostępny. Możliwe przyczyny błędu :

  1. Nie wystartował silnik Pervasive.
  2. Brak komunikacji sieciowej lub niepoprawne ustawienia w Pervasive dla klienta.

 

Zazwyczaj błąd występuje wówczas gdy nie uruchomił się lokalnie silnik bazy danych. Przeważnie jest to błąd dotyczący serwera. W przypadku gdy problem wystąpi na stacji roboczej oznacza to, iż Pervasive jest nieprawidłowo skonfigurowany. Wówczas Symfonia próbuje korzystać z lokalnego silnika bazy danych, gdzie powinna korzystać z serwera.

 

 

Aby sprawdzić status licencji Pervasive:

  1. Uruchom Control Center & Documentation
  2. Sprawdzić ustawienia dla Klienta za pomocą Configure Microkernel Router :

Use Local Microkernel Engine - ustaw na: OFF

Use Remote Microkernel Engine - ustawa na: ON

Target Engine  - ustawa na: Serwer Only

Use IDS - ustaw na: OFF

Communication Protocols -> Supported Protocols - ustaw na: TCP/IP

 

 

Po zmianie konfiguracji klient Pervasive powinien łączyć się do serwera.

 

 

Uwaga!

Jeśli po zmianie parametrów w Pervasive na stacji roboczej pojawi się błąd 3014 oznacza to, że konfiguracja jest poprawna, ale występuje problem w komunikacji sieciowej pomiędzy stacją roboczą a serwerem. Wówczas należy zastosować się do instrukcji związanej z błędem 3014.

 

Czy ten artykuł był pomocny?

Liczba użytkowników, którzy uważają ten artykuł za przydatny: 0 z 7